Tag Archives fornpm

FSEvents not compatible with your operating system or architecture

NPM logoWhile installing the React Native examples I ran into the following error when running the npm install  command:

 

npm ERR! notsup Unsupported
npm ERR! notsup Not compatible with your operating system or architecture: fsevents@1.0.5
npm ERR! notsup Valid OS: darwin
npm ERR! notsup Valid Arch: any
npm ERR! notsup Actual OS: linux
npm ERR! notsup Actual Arch: x64

This error message says that fsevents package does not support my operating system. In my case the solution for this error was to upgrade npm to the latest version. I was still using npm 2.x, and after upgrading to npm 3.3.12 the error was gone.

November 30, 2015